NEWS • COMPETITIVE

GPL in 2018 and Beyond
Posted on 02/08/2018 by LoL PH Admin


 


We're announcing the end of League of Legends' support for Windows XP Service Pack 2. If you are on an operating system using Windows XP Service Pack 2, check out the steps below to avoid an interruption of service. The support is scheduled to end on XXX,2018. 

Why am I required to upgrade?

Service Pack 2 is no longer compatible with the latest security protocols. This isn't a change to League itself, but a required security update to the connection between players and our servers. The only versions of Windows compatible with the latest protocols are XP Service Pack 3 and above for 32-bit, and Vista and above for 64-bit.

That said, Microsoft hasn't released security updates for XP since early 2014, so while you'll be able to keep playing League on Service Pack 3 you'll still be vulnerable to risks which could compromise your League account. If at all possible we recommend updating to a newer version of Windows.

What will happen if I don't upgrade?

Unsupported systems might not be able to communicate with our servers and anyone still running Service Pack 2 won't be able to log in or play the game.

How do I know which Service Pack I have installed?

  • Click on Start and then Control Panel.
  • Click on the Performance and Maintenance link. If you're using Classic View for the Control Panel, double-click the System icon and proceed to Step 4.
  • In the Performance and Maintenance window, click on the System Control Panel icon at the bottom of the window.
  • When the System Properties window opens it should default to the General tab. If not, choose it manually.
  • In the System: area of the General tab you'll find the operating system version and service pack level. If you don't have a service pack installed, you'll only see your operating system version.

How do I upgrade?

If you're on a 32-bit OS, you can download and install Windows XP Service Pack 3 for free here.
If you're on a 64-bit OS, you'll need to upgrade to Vista or later. Please visit Microsoft's website for support here.